IsDown.app is inaccessible.

Service Documentation
Impact Critical
Started November 08, 2023 at 03:49 PM UTC

Resolved

November 08, 2023 at 03:53 PM UTC • Duration: 4 minutes

Incident Updates

Investigating

We are currently investigating this issue.

Resolved

We're back online. Seems it was a Cloudflare issue.