IsDown is currently unacessible

Service Monitors ( Third-party services ), Monitors ( Custom services ), Webhooks, Zapier, Slack, Emails, Datadog, API, PagerDuty, Status Pages, Microsoft Teams, Google Chat, Discord, Documentation
Impact Major
Started June 12, 2025 at 06:24 PM UTC

Resolved

June 12, 2025 at 07:25 PM UTC • Duration: about 1 hour

Incident Updates

Investigating

We are currently investigating this issue.

Monitoring

A fix has been implemented and we are monitoring the results.

Monitoring

We are continuing to monitor for any further issues.

Resolved

This incident has been resolved.