There are reports of multiple emails being received for service recovery

Service Webhooks, Zapier, Slack, Emails, Datadog, PagerDuty, Microsoft Teams, Google Chat, Discord
Impact Minor
Started April 20, 2023 at 05:37 PM UTC

Resolved

April 20, 2023 at 08:48 PM UTC • Duration: about 3 hours

Incident Updates

Investigating

We are currently investigating this issue.

Identified

It seems the issue only affected customers that are monitoring Slack service. They got 5 extra recovery notifications (we're sorry for the noise). We've disabled the Slack status page monitoring while we understand the issue.

Resolved

This incident has been resolved.