Email provider is having issues and email notifications are delayed

Service Emails
Impact Major
Started April 15, 2024 at 05:22 PM UTC

Resolved

April 15, 2024 at 07:23 PM UTC • Duration: about 2 hours

Incident Updates

Identified

We're working with the third-party provider to fix this quickly.

Resolved

This incident has been resolved.