Application isn't loading

Service Webhooks, Zapier, Slack, Emails, Documentation
Impact Critical
Started April 20, 2022 at 11:25 AM UTC

Resolved

April 20, 2022 at 11:42 AM UTC • Duration: 17 minutes

Incident Updates

Investigating

We are currently investigating this issue.

Monitoring

3rd party database provider recovered from the issue. We'll continue to monitor it to make sure it's stable.

Resolved

This incident has been resolved.