Delay delivering email notifications

Service Emails
Impact Critical
Started March 03, 2023 at 10:13 PM UTC

Resolved

March 03, 2023 at 10:19 PM UTC • Duration: 6 minutes

Incident Updates

Identified

We’re having an issue with our third party provider which is causing a delay in email notifications. We already contacted the provider to try to get it fixed ASAP. A workaround is set another notification channel.

Resolved

This incident has been resolved.