IsDown.app is current inaccessible

Service Documentation
Impact Critical
Started February 01, 2025 at 02:36 PM UTC

Resolved

February 01, 2025 at 02:45 PM UTC • Duration: 9 minutes

Incident Updates

Investigating

We are currently investigating this issue.

Monitoring

The website is now accessible again. We will continue to monitor to understand if it fully recovered.

Resolved

This incident has been resolved.