Issues with status page provider

Service Monitors ( Third-party services )
Impact Minor
Started October 20, 2025 at 09:52 AM UTC

Resolved

October 20, 2025 at 10:04 AM UTC • Duration: 12 minutes

Incident Updates

Resolved

Queues are back to normal.

Monitoring

There's an ongoing AWS outage that affects a great part of the internet, and especially one big status page provider where we collect the data.

We're going through the queue as it seems to be recovering.

Sorry for the delay.